Opened 14 years ago

Closed 14 years ago

#167 closed task (fixed)

shadow-4.1.2 don't need the installation of libshadow.*

Reported by: Brunno Owned by: Joe Ciccone
Priority: major Milestone: CLFS Standard 1.1.0
Component: BOOK Version: CLFS Standard 1.1.0
Keywords: Cc:

Description

I get an error when trying to move the libraries libshadow.{a,la,so} step of installation of shadow-4.1.2.

I search about this error in google and found this ticket: http://wiki.linuxfromscratch.org/lfs/ticket/2144

That page says that libraries are no longer necessary because the only programs that needed them were the tools of shadow and they no longer use them more in this version. Because of that they disabled the installation of them.

For CLFS development version this is true too? If yes, the book need to be updated

Change History (3)

comment:1 Changed 14 years ago by Joe Ciccone

The libraries are no longer installed in more recent versions of shadow. The commands have been removed from the pages in r3945.

Now that these libraries are no longer installed we will only need one installation of shadow on multilib. I'll save that change until after I finish my next multilib build.

comment:2 Changed 14 years ago by Joe Ciccone

Owner: changed from clfs-commits@… to Joe Ciccone

comment:3 Changed 14 years ago by Joe Ciccone

Resolution: fixed
Status: newclosed

Removed the extra shadow builds on multilib in r3954

Note: See TracTickets for help on using tickets.