Opened 13 years ago

Closed 12 years ago

#152 closed defect (wontfix)

Only ppc and ppc64 are using the glibc branch update patch in chapter 5

Reported by: ken Owned by: clfs-commits@…
Priority: minor Milestone: CLFS Standard 1.1.0
Component: BOOK Version: CLFS Standard 1.1.0
Keywords: Cc:

Description

At the moment, this doesn't matter too much because those were the only arches affected by the code in the patch when it was in the original version (and we do apply the update with the altered docs to the final system), but it looks messy.

The original version of the patch was needed for ppc and ppc64, but only with --enable-kernel=2.6.22 (or later), and prevents glibc compiling with --enable-kernel=2.6.0 which is what we have in the book. Maybe we should just drop the patch completely, because all the cut-down version is doing is updating some documentation ?

Change History (2)

comment:1 Changed 12 years ago by Joe Ciccone

Milestone: CLFS Standard 1.2.0CLFS Standard 1.1.0
Version: CLFS Standard 1.1.0

No objections from me. Like you said, it doesn't make any code changes and only causes problems on ppc.

comment:2 Changed 12 years ago by Joe Ciccone

Resolution: wontfix
Status: newclosed

I'm going to resolve this at wontfix because of the updated patch ken committed months back. It fixes the problem with ppc, still updates the documentation. Glibc 2.8 will be out soon and this patch will be irrelevant anyway. At least the documentation will be up to date.

Note: See TracTickets for help on using tickets.