Opened 13 years ago

Closed 13 years ago

#94 closed defect (fixed)

Inetutils telnet binary fails on amd64

Reported by: Jeremy Utley Owned by: clfs-commits@…
Priority: blocker Milestone: CLFS Standard 1.0.0
Component: BOOK Version: CLFS Standard 1.0.0
Keywords: Cc:

Description

on amd64 (at least multilib) the telnet binary from inetutils fails to do proper DNS resolution for all hosts:

jeremy@valkyrie:~$ telnet localhost Trying 255.255.255.255... telnet: Unable to connect to remote host: Network is unreachable

jeremy@valkyrie:~$ telnet www.google.com Trying 255.255.255.255... telnet: Unable to connect to remote host: Network is unreachable

ping and other netkit binaries work as expected.

This is a blocker for the 1.0.0 release - Ryan might have a patch, which I'm testing shortly

Attachments (1)

inetutils-1.4.2-telnet_fix-1.patch (782 bytes) - added by Jeremy Utley 13 years ago.
Interim Patch to fix this issue

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by Jeremy Utley

Interim Patch to fix this issue

comment:1 Changed 13 years ago by Jeremy Utley

Problem initially reported on IRC by Vladimir Vainer (ferreus). I verified on my own multilib build and the problem does exist.

comment:2 Changed 13 years ago by Jeremy Utley

A few more notes on this one. This bug has been known to exist by the maintainer since at least 1999:

http://sources.redhat.com/ml/bug-gnu-utils/1999-06/msg00114.html

Also a reference to a discussion on the LFS lists:

http://linuxfromscratch.org/pipermail/lfs-support/2005-January/025824.html

This is confirmed to be a 64bit bug - I compiled inetutils as a 32-bit binary on my system, and telnet works as expected.

comment:3 Changed 13 years ago by Jim Gifford

Resolution: fixed
Status: newclosed

Fixed in r2605

Note: See TracTickets for help on using tickets.