Opened 14 years ago

Closed 14 years ago

#170 closed task (fixed)

udev 64 override of libvolume_id.so.0 32

Reported by: Brunno Owned by: clfs-commits@…
Priority: major Milestone: CLFS Standard 1.1.0
Component: BOOK Version: CLFS Standard 1.1.0
Keywords: Cc:

Description

I installed the CLFS version of this development and all working well. But I had problems installing the package HAL, as directed by CBLFS wiki. After many attempts saw that the problem is installing the package udev-124 of CLFS, the patch forcing the directory lib64 worked for almost everything except the libvolume.so.0, which is installed in /lib and not in /lib64, overriding the 32-bit version. In my attempts, before reinstalling udev, i changed in the Makefile from /lib to /lib64 in extra/volume_id/lib directory, then the installation placed in the right place, but even then the package HAL (64 bit) can not find libvolume_id.so.0, i copied the file extras/volume_id/lib/libvolume_id.pc from the compilation of udev-124, into the /usr/lib64/pkgconfig and i rather the hal find the library.

Change History (1)

comment:1 Changed 14 years ago by Joe Ciccone

Resolution: fixed
Status: newclosed

Confirmed and Fixed in r3958.

Note: See TracTickets for help on using tickets.