Opened 4 years ago

Closed 4 years ago

#1096 closed task (duplicate)

Host System Requirements Check

Reported by: William Harrington Owned by: clfs-commits@…
Priority: trivial Milestone: CLFS Standard 3.1.0
Component: BOOK Version: CLFS Standard GIT
Keywords: Cc: berzerkula@…, jonathan@…, chris@…, cross-lfs@…

Description

Chris mentioned the notion to check our Host System Requirements section.

I have been testing with the updated lfs livecd which is based on 6.3 with my own updates: http://clfs.org/~kb0iic/livecdupd/

So far GCC needs to be upgraded to at least 4.2.3 because of binutils and gold requirements.

ISL 0.15 has a header issue which causes issues with compilers that don't default to C99 and a comma exists at the end of a structure: https://groups.google.com/d/msg/isl-development/olvv6MU_3gE/VMf8qzZLCQAJ

Editing the header in ISL for cross-tools is okay, or force 4.2.3 to use c99 for ISL 0.15.

Chris found some issues, but I'm still at gcc-static right now.

Change History (1)

comment:1 Changed 4 years ago by William Harrington

Resolution: duplicate
Status: newclosed

Duplicate of Ticket 1095

Note: See TracTickets for help on using tickets.