Opened 4 years ago

Closed 4 years ago

#1094 closed task (fixed)

GCC 5.3

Reported by: William Harrington Owned by: clfs-commits@…
Priority: major Milestone: CLFS Standard 3.1.0
Component: BOOK Version: CLFS Standard GIT
Keywords: Cc: berzerkula@…, jonathan@…, chris@…, cross-lfs@…

Description

This is a bug fix:

https://gcc.gnu.org/gcc-5/

https://gcc.gnu.org/ml/gcc-announce/2015/msg00004.html

Our branch update patch probably includes most changes up to 5.3. 5.3 should be a direct drop in without issues.

Change History (5)

comment:2 Changed 4 years ago by William Harrington

I have completed a sysvinit jhalfs build with gcc 5.3.0 and kept the same instructions except removed the 5.2.0 upstream patch. All had no errors. Has anyone else built with gcc 5.3.0 with CLFS 32bit or pure 64bit?

comment:3 Changed 4 years ago by Martin Ward

Building a pure 64 system at the moment seems to be a drop in replacement with no regressions above the usaul errors using previous versions of GCC

Last edited 4 years ago by Martin Ward (previous) (diff)

comment:4 Changed 4 years ago by William Harrington

Milestone: CLFS Standard 3.1.0

comment:5 Changed 4 years ago by William Harrington

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.