Ticket #16 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

Util-Linux - Fdisk

Reported by: jim Owned by: clfs-commits@…
Priority: blocker Milestone: CLFS Standard 1.0.0
Component: BOOK Version: CLFS Standard 1.0.0
Keywords: Cc:

Description

With the GCC 4.1 and Glibc 2.4, we have had reports of Linux 2.6.16.x having problems correctly identifying the hard drives, which prevents the hard disks from getting created by udev. A fix to util-linux is needed, I have wrote the maintainer to get his input, have not received any information back.

Have worked with Sparc Linux, it seems to be an issue with disks that fdisk creates the sun-disk label. We need people to test the other architectures. I have tests the following and do not have these issues with fdisk, incase it's a GCC 4.1 and GLIBC 2.4 issues.

x86 and MIPS are not affected by this.

A temporary solution would be to pull in parted, like we do for PPC. Parted does not show the same issues and is a valid work around.

Change History

comment:1 Changed 12 years ago by jciccone

  • Status changed from new to closed
  • Resolution set to fixed

fixed in r1385

comment:2 Changed 12 years ago by jciccone

  • Status changed from closed to reopened
  • Resolution fixed deleted

This ticket is being re-opened because the current solution is flawed. The checksum generated by the changes in the patchs will always be 0. This is definitaly not desired. The problem is in gcc and a bug has been opened with gcc,  http://gcc.gnu.org/bugzilla/show_bug.cgi?id=27176

comment:3 Changed 12 years ago by jciccone

One proper fix for this is to add -fno-tree-loop-optimize to CFLAGS. This goes for both util-linux and the linux kernel. Alternativly, gcc can be patched. Patching gcc will fix the packages that we are not aware of that may be affected by this problem.

comment:4 Changed 12 years ago by jciccone

  • Status changed from reopened to closed
  • Resolution set to fixed

the util-linux and kernel patches have been removed and the gcc patch was put in in r1402. This properly fixes the issue.

comment:5 Changed 11 years ago by jim

  • Version changed from unstable to 1.0.0
Note: See TracTickets for help on using tickets.