Ticket #117 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

Invalid commands to create ppc-tools

Reported by: Moody Owned by: manuel@…
Priority: major Milestone:
Component: BOOK Version:
Keywords: Cc:

Description

jhalfs produces invalid sequence of commands for the powerpc-utils.

151-powerpc-utils:  150-parted
        @$(call echo_message, Building)
        @$(SHELL) progress_bar.sh $@ $$PPID &
        @echo "$(nl_)`date`$(nl_)" >logs/$@
        @$(PRT_DU_CR) >>logs/$@
        @( time { source envars && $(crCMDSDIR)/final-system/$@ >>logs/$@ 2>&1 ; } ) 2>>logs/$@ && \
        $(PRT_DU_CR) >>logs/$@
        @$(call housekeeping)

Change History

comment:1 in reply to: ↑ description Changed 10 years ago by Moody

Replying to Moody:

Sorry i accidently clicked on submit while I was about to click on preview...

There are no commands to extract the package. Than it uses the $PKGDIR from the previously built package (parted) which is wrong here...

comment:2 Changed 10 years ago by jim

  • Owner changed from clfs-commits@… to manuel

comment:3 Changed 10 years ago by jim

  • Owner changed from manuel to manuel@…

comment:4 Changed 10 years ago by Moody

This is caused by the underline-character in the filename of the tarball. It seems that the difficuties are caused in the "common/urls.xsl" trying to extract the package name by stripping off all right from a minus (-) followed by digit(s). In this case, this does not work cause there is no - left from the version (this is the _).

For testing, I renamed the powerpc-utils_1.13... to powerpc-utils-1.13... and patched the {packages,patches}.ent and the build went fine.

comment:5 Changed 10 years ago by manuel@…

  • Status changed from new to closed
  • Resolution set to fixed

I not noticed this ticket until now, sorry.

The bug was due a missing entry for powerpc-utils in get_package_tarball_name() function found on common/libs/func_wrt_Makefile.

It should be fixed on current jhalfs SVN code.

Issues related with jhalfs is better to report they on alfs-discuss mailing list for more quick fixes ;-)

Note: See TracTickets for help on using tickets.