source: scripts/scripts/untested/blfs-scripts/blfs-packages-20050806 @ 0b402ff

clfs-1.2clfs-2.1clfs-3.0.0-systemdclfs-3.0.0-sysvinitsystemdsysvinit
Last change on this file since 0b402ff was 0b402ff, checked in by Jim Gifford <clfs@…>, 15 years ago

r698@server (orig r696): ryan | 2005-11-13 00:00:47 -0800

r704@rei: lfs | 2005-11-13 19:01:08 +1100
Import updates for untested blfs-scripts



  • Property mode set to 100644
File size: 5.0 KB
Line 
1#!/bin/bash
2
3export OPENEXR_VER=1.2.2
4
5# needs work to support newer arches
6export A2PS_VER=4.13b
7
8export A52DEC_VER=0.7.4
9export AALIB_VER=1.4rc4
10export ALSA_LIB_VER=1.0.8
11export ALSA_TOOLS_VER=1.0.8
12export ALSA_UTILS_VER=1.0.8
13
14# see notes concerning issues
15export ASPELL_VER=0.60.2                # needs wrapper
16
17export CDPARANOIA_VER=alpha9.8
18export CDK_VER=5.0-20050424
19export CUPS_VER=1.1.23                  # needs wrapper
20
21export DBUS_VER=0.33
22export DT_FILE_UTILS_VER=0.10
23export DBK_DSSSL_VER=1.79
24#export DBK_SGML_VER=4.4
25export DBK_SGML_VER=3.1
26export DBK_UTILS_VER=0.6.14
27
28# check script can handle version, see notes
29export DBK_XML_DTD_VER=4.4
30# check script can handle version, see notes
31export DBK_XSL_VER=1.67.2
32export DBUS_VER=0.35.2
33
34export DIRECTFB_VER=0.9.22
35
36export DOXYGEN_VER=1.4.2
37export ED_VER=0.2
38export EXIF_VER=0.6.9
39export ENSCRIPT_VER=1.6.4
40
41export ESPGS_VER=7.07.1
42export GS_FONTS_STD_VER=8.11
43export GS_FONTS_OTHER_VER=6.0
44
45export FAM_VER=
46
47export FAAC_VER=1.24
48export FAAD2_VER=2.0
49export FLAC_VER=1.1.2
50export FFMPEG_VER=20050806
51export FFTW_VER=2.1.5
52export FFTW3_VER=3.0.1
53export FLTK_VER=1.1.6                   # needs wrapper
54
55# Foomatic filter setup for cups is gonna need work...
56# check if CC/CFLAGS need to be defined
57export FOOMATIC_DB_VER=20050514
58export FOOMATIC_DB_HPIJS_VER=1.5
59export FOOMATIC_FILTERS_VER=3.0.2
60export FOOMATIC_DB_ENG_VER=3.0.2
61
62export FREEGLUT_VER=2.2.0
63
64export GAMIN_VER=0.1.1
65
66export GD_VER=2.0.33                    # needs wrapper
67export GDBM_VER=1.8.3
68export GEXIF_VER=0.5
69export GIFLIB_VER=4.1.3
70export GIMP_PRINT_VER=4.2.7             # needs wrapper
71export GLIB12_VER=1.2.10                # needs wrapper
72export GPHOTO2_VER=2.1.6
73
74# check LIBPOSTFIX in configure for mips
75export GRAPHVIS_VER=2.2.1               # needs wrapper
76
77export GSM_VER=1.0.10
78
79export GTK12_VER=1.2.10                 # needs wrapper
80export HAL_VER=0.5.3
81export HC_ICON_THEME_VER=0.8
82export HOWL_VER=1.0.0
83export ID3LIB_VER=3.8.3
84export IJS_VER=0.35                     # needs wrapper
85export IMLIB2_VER=1.2.1
86export JADETEX_VER=3.13
87export JASPER_VER=1.701.0
88
89# lcms has issues... see notes
90export LCMS_VER=1.14
91
92export LAME_VER=3.96.1
93
94# check notes on need to edit mxmkmf
95export LESSTIF_VER=0.94.4               # needs wrapper
96
97export LIBAO_VER=0.8.6
98export LIBCACA_VER=0.9
99export LIBDVDCSS_VER=1.2.9
100
101export LIBEXIF_VER=0.6.12
102export LIBEXIFGTK_VER=0.3.5
103export LIBFAME_VER=0.9.1
104export LIBGPHOTO2_VER=2.1.6
105export LIBIDN_VER=0.5.16
106
107export LIBIEEE1284_VER=0.2.10
108# libjpeg is a GODDAMNED FIGHT building on x86_64, needs fixing
109export LIBJPEG_VER=v6b
110
111export LIBMAD_VER=0.15.1b
112#export LIBMIKMOD_VER=3.2.0-beta2
113export LIBMIKMOD_VER=3.1.11
114export LIBMODPLUG_VER=0.7
115
116# Check setting of PREFIX for header fixups, check setting of MACHINE
117export LIBMPEG3_VER=1.5.4
118
119export LIBMNG_VER=1.0.9
120export LIBNTLM_VER=0.3.7
121
122export LIBOGG_VER=1.1.2
123export LIBPAPER_VER=1.1.14
124
125# requires a device node created... revisit for udev
126export LIBRAW1394_VER=1.2.0
127export LIBSNDFILE_VER=1.0.12oggflac
128export LIBSAMPLERATE_VER=0.1.2
129
130export LIBTHEORA_VER=1.0alpha4
131export LIBUSB_VER=0.1.10a
132export LIBVORBIS_VER=1.1.0
133export LIBXVMCW_VER=0.9.3
134
135# Additional requirements, see script
136export LM_SENSORS_VER=2.9.1
137
138export LYNX_VER=2.8.5
139
140# Check patch requirements for amd64 etc... check script for other needed fixes
141export MAS_VER=0.6.3                    # Needs wrapper
142
143export MDNS_VER=107.1
144export MTOOLS_VER=3.9.10
145export MYSQL_VER=4.1.11                 # needs wrapper and header mods
146export NAS_VER=1.7
147
148# double check this script... only builds 32
149export NASM_VER=0.98.38
150
151export NCOMPRESS_VER=4.2.4
152
153# libtool barfage, may be fixed now...
154export OPENJADE_VER=1.3.2 
155export OPENSP_VER=1.5.1                 # needs header fixes
156export PCRE_VER=5.0                     # needs wrapper
157export PGSQL_VER=8.0.3
158export PKGCONFIG_VER=0.17.2
159export POPT_VER=1.7
160export POLYPAUDIO_VER=0.7
161
162# check setting CC is correct...
163export PSUTILS_VER=p17
164
165# will probably need edits for lib32
166export PYTHON_VER=2.4.1
167export PYREX_VER=0.9.3
168
169# Much more needs to be done for mips etc
170# needs wrapper and header mods
171# Also note the QT_INSTALL_SELF_CVONTAINED env var for putting it in /opt
172export QT_VER=3.3.4
173
174#revisit this script re --with-libdir= vs --libdir=
175export SAMBA_VER=3.0.14a
176export SANE_BACKENDS_VER=1.0.15
177export SDL_VER=1.2.8
178export SGML_COMMON_VER=0.6.3
179export SGMLSPM_VER=1.03ii
180export SHARUTILS_VER=4.3.80
181export SHD_MIME_INFO_VER=0.16
182export SLANG_VER=1.4.9
183export SPEEX_VER=1.1.10
184
185# TODO: Look into swig builds when multilib... read script for details
186#       Work will need to be done, script hasn't been touched
187export SWIG_VER=1.3.24
188export SYSFSUTILS_VER=1.3.0
189
190export T1LIB_VER=5.1.0
191export TETEX_VER=3.0
192export TIFF_VER=3.7.2
193export TK_VER=8.4.9
194export TK_PM_VER=804.027
195export UNIXODBC_VER=2.2.11
196# Check unzip to see how to apply target specific cflags, default env etc
197export UNZIP_VER=552
198
199export WINE_VER=20050628
200export WHICH_VER=2.16
201export X264_VER=svn-20050731
202export XINE_LIB_VER=1.1.0
203export XINE_UI_VER=0.99.4
204export XMLTO_VER=0.0.18
205export XMMS_VER=1.2.10                  # needs wrapper
206export XPDF_VER=3.00
207
208# need to make sure perl uses a wrapper
209export XML_PARSER_PM_VER=2.34
210export XVID_VER=1.1.0-beta2
211
212export YASM_VER=0.4.0
213
214export ZIP_VER=231
Note: See TracBrowser for help on using the repository browser.