source: clfs-embedded/BOOK/prologue/common/hostreqs.xml @ 5e492c0

Last change on this file since 5e492c0 was 5e492c0, checked in by Andrew Bradford <andrew@…>, 10 years ago

hostreqs: Update to minimum of Debian Squeeze

Squeeze goes end of support life in < 1 year and it already had quite
old software packaged in it. Testing against even older versions than
what Debian ships seems unlikely to be useful or possible for much
longer.

  • Property mode set to 100644
File size: 3.2 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3  "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4  <!ENTITY % general-entities SYSTEM "../../general.ent">
5  %general-entities;
6]>
7
8<sect1 id="pre-hostreqs">
9  <?dbhtml filename="hostreqs.html"?>
10
11  <title>Host System Requirements</title>
12
13    <para>You should be able to build a CLFS system from just about any
14    recent Linux distrubtion. Your host system should have the following
15    software with the minimum versions indicated. Also note that many
16    distributions will place software headers into separate packages, often in
17    the form of <quote>[package-name]-devel</quote> or
18    <quote>[package-name]-dev</quote>. Be sure to install those if
19    your distribution provides them.</para>
20
21  <itemizedlist spacing="compact">
22
23    <listitem>
24      <para><emphasis role="strong">Bash 4.0</emphasis></para>
25    </listitem>
26
27    <listitem>
28      <para><emphasis role="strong">Binutils-2.20</emphasis></para>
29    </listitem>
30
31    <listitem>
32      <para><emphasis role="strong">Bzip2-1.0.5</emphasis></para>
33    </listitem>
34
35    <listitem>
36      <para><emphasis role="strong">Coreutils-8.1</emphasis></para>
37    </listitem>
38
39    <listitem>
40      <para><emphasis role="strong">Diffutils-3.0</emphasis></para>
41    </listitem>
42
43    <listitem>
44      <para><emphasis role="strong">Findutils-4.4.0</emphasis></para>
45    </listitem>
46
47    <listitem>
48      <para><emphasis role="strong">Gawk-3.1</emphasis></para>
49    </listitem>
50
51    <listitem>
52      <para><emphasis role="strong">Gcc-4.4</emphasis></para>
53    </listitem>
54
55    <listitem>
56      <para><emphasis role="strong">Glibc-2.11</emphasis></para>
57    </listitem>
58
59    <listitem>
60      <para><emphasis role="strong">Grep-2.6</emphasis></para>
61    </listitem>
62
63    <listitem>
64      <para><emphasis role="strong">Gzip-1.3</emphasis></para>
65    </listitem>
66
67    <listitem>
68      <para><emphasis role="strong">Make-3.81</emphasis></para>
69    </listitem>
70
71    <listitem>
72      <para><emphasis role="strong">Patch-2.6</emphasis></para>
73    </listitem>
74
75    <listitem>
76      <para><emphasis role="strong">Sed-4.2.1</emphasis></para>
77    </listitem>
78
79    <listitem>
80      <para><emphasis role="strong">Tar-1.23</emphasis></para>
81    </listitem>
82
83  </itemizedlist>
84
85  <para>To see whether your host system has all the appropriate versions, run the following:</para>
86
87<screen role="nodump"><userinput>cat &gt; version-check.sh &lt;&lt; "EOF"
88<literal>#!/bin/bash
89
90# Simple script to list version numbers of critical development tools
91
92bash --version | head -n1 | cut -d" " -f2-4
93echo -n "Binutils: "; ld --version | head -n1 | cut -d" " -f3-
94bzip2 --version 2&gt;&amp;1 &lt; /dev/null | head -n1 | cut -d" " -f1,6-
95echo -n "Coreutils: "; chown --version | head -n1 | cut -d")" -f2
96diff --version | head -n1
97find --version | head -n1
98gawk --version | head -n1
99gcc --version | head -n1
100ldd $(which ${SHELL}) | grep libc.so | cut -d ' ' -f 3 | ${SHELL} | head -n 1 | cut -d ' ' -f 1-7
101grep --version | head -n1
102gzip --version | head -n1
103make --version | head -n1
104patch --version | head -n1
105sed --version | head -n1
106tar --version | head -n1</literal>
107
108EOF
109
110bash version-check.sh</userinput></screen>
111
112</sect1>
Note: See TracBrowser for help on using the repository browser.