source: BOOK/prologue/common/hostreqs.xml @ f7a6c6f

clfs-2.1clfs-3.0.0-systemdclfs-3.0.0-sysvinitsystemdsysvinit
Last change on this file since f7a6c6f was f7a6c6f, checked in by Chris Staub <chris@…>, 10 years ago

Slight improvements to host reqs. script

  • Property mode set to 100644
File size: 4.7 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3  "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4  <!ENTITY % general-entities SYSTEM "../../general.ent">
5  %general-entities;
6]>
7
8<sect1 id="pre-hostreqs">
9  <?dbhtml filename="hostreqs.html"?>
10
11  <title>Host System Requirements</title>
12
13    <para>You should be able to build a CLFS system from just about any
14    Unix-type operating system. Your host system should have the following
15    software with the minimum versions indicated. Also note that many
16    distributions will place software headers into separate packages, often in
17    the form of <quote>[package-name]-devel</quote> or
18    <quote>[package-name]-dev</quote>. Be sure to install those if
19    your distribution provides them.</para>
20
21  <itemizedlist spacing="compact">
22
23    <listitem>
24      <para><emphasis role="strong">Bash-2.05a</emphasis></para>
25    </listitem>
26
27    <listitem>
28      <para><emphasis role="strong">Binutils-2.12</emphasis> (Versions
29      greater than &binutils-version; are not recommended as they have
30      not been tested)</para>
31    </listitem>
32
33    <listitem>
34      <para><emphasis role="strong">Bison-1.875</emphasis></para>
35    </listitem>
36
37    <listitem>
38      <para><emphasis role="strong">Bzip2-1.0.2</emphasis></para>
39    </listitem>
40
41    <listitem>
42      <para><emphasis role="strong">Coreutils-5.0</emphasis></para>
43    </listitem>
44
45    <listitem>
46      <para><emphasis role="strong">Diffutils-2.8</emphasis></para>
47    </listitem>
48
49    <listitem>
50      <para><emphasis role="strong">Findutils-4.1.20</emphasis></para>
51    </listitem>
52
53    <listitem>
54      <para><emphasis role="strong">Gawk-3.1.5</emphasis></para>
55    </listitem>
56
57    <listitem>
58      <para><emphasis role="strong">GCC 4.1</emphasis> (Versions
59      greater than &gcc-version; are not recommended as they have not
60      been tested)</para>
61    </listitem>
62
63    <listitem>
64      <para><emphasis role="strong">Glibc-2.2.5</emphasis> (Versions
65      greater than &eglibc-version; are not recommended as they have
66      not been tested)</para>
67    </listitem>
68
69    <listitem>
70      <para><emphasis role="strong">Grep-2.5</emphasis></para>
71    </listitem>
72
73    <listitem>
74      <para><emphasis role="strong">Gzip-1.2.4</emphasis></para>
75    </listitem>
76
77   <listitem>
78     <para><emphasis role="strong">Linux 2.6.32 (Built with GCC 4.1.2 or later)</emphasis></para>
79   </listitem>
80
81    <listitem>
82      <para><emphasis role="strong">Make-3.80</emphasis></para>
83    </listitem>
84
85    <listitem>
86      <para><emphasis role="strong">Ncurses-5.3</emphasis></para>
87    </listitem>
88
89    <listitem>
90      <para><emphasis role="strong">Patch-2.5.4</emphasis></para>
91    </listitem>
92
93    <listitem>
94      <para><emphasis role="strong">Sed-3.0.2</emphasis></para>
95    </listitem>
96
97    <listitem>
98      <para><emphasis role="strong">Tar-1.22</emphasis></para>
99    </listitem>
100
101    <listitem>
102      <para><emphasis role="strong">Texinfo-4.7</emphasis></para>
103    </listitem>
104
105    <listitem>
106      <para><emphasis role="strong">XZ-Utils-4.999.8beta</emphasis></para>
107    </listitem>
108
109  </itemizedlist>
110
111  <para>To see whether your host system has all the appropriate versions,
112  create and run the following script. Read the output carefully for any
113  errors, and make sure to install any packages that are reported as not found.</para>
114
115<screen role="nodump"><userinput>cat &gt; version-check.sh &lt;&lt; "EOF"
116<literal>#!/bin/bash
117
118# Simple script to list version numbers of critical development tools
119
120bash --version | head -n1 | cut -d" " -f2-4
121echo -n "Binutils: "; ld --version | head -n1 | cut -d" " -f3-
122bison --version | head -n1
123bzip2 --version 2&gt;&amp;1 &lt; /dev/null | head -n1 | cut -d" " -f1,6-
124echo -n "Coreutils: "; chown --version | head -n1 | cut -d")" -f2
125diff --version | head -n1
126find --version | head -n1
127gawk --version | head -n1
128gcc --version | head -n1
129ldd $(which ${SHELL}) | grep libc.so | cut -d ' ' -f 3 | ${SHELL} | head -n 1 | cut -d ' ' -f 1-7
130grep --version | head -n1
131gzip --version | head -n1
132uname -s -r
133make --version | head -n1
134tic -V
135patch --version | head -n1
136sed --version | head -n1
137tar --version | head -n1
138makeinfo --version | head -n1
139xz --version | head -n1
140echo 'main(){}' | gcc -v -o /dev/null -x c - > dummy.log 2>&amp;1
141if ! grep -q ' error' dummy.log; then
142  echo "Compilation successful" &amp;&amp; rm dummy.log
143else
144  echo 1>&amp;2  "Compilation FAILED - more development packages may need to be \
145installed. If you like, you can also view dummy.log for more details."
146fi</literal>
147EOF
148
149bash version-check.sh 2>errors.log &amp;&amp;
150[ -s errors.log ] &amp;&amp; echo -e "\nThe following packages could not be found:\n$(cat errors.log)"</userinput></screen>
151
152</sect1>
Note: See TracBrowser for help on using the repository browser.