Ticket #62 (closed defect: invalid)

Opened 11 years ago

Last modified 11 years ago

Bogus m4 host requirement in CLFS-2.0

Reported by: alexander@… Owned by: clfs-commits@…
Priority: major Milestone: CLFS Sysroot 1.0.0
Component: BOOK Version: CLFS Sysroot 1.0.0
Keywords: hostdep Cc:

Description

To reproduce: install Debian Etch, then run there "apt-get install gawk build-essential". Gawk is for iana-etc. Then try building CLFS-2.0 from there. The build will fail on Bison because of missing m4.

However, m4 is only a run-time requirement for bison, so some pre-seeding of config.cache should happen to avoid this host dependency.

Change History

comment:1 Changed 11 years ago by alexander@…

Forget it. m4 is required for autoconf, so it is indeed a host requirement.

comment:2 Changed 11 years ago by jciccone

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.