Ticket #122 (closed defect: invalid)

Opened 10 years ago

Last modified 10 years ago

A few object files should be coppied before running gcc make

Reported by: ravidbn Owned by: clfs-commits@…
Priority: major Milestone:
Component: BOOK Version:
Keywords: Cc:

Description

I'm building a cross compiled LFS using x86_64-unknown-linux-gnu as my host and i686-pc-linux-gnu as my target. In chapter "5.8. GCC-4.1.1 - Cross Compiler Final" before running the command:

make AS_FOR_TARGET="${CLFS_TARGET}-as" LD_FOR_TARGET="${CLFS_TARGET}-ld"

Another few actions should be added: cp -v ${PRRFIX}/lib/crti.o /cross-tool/${CLFS_TARGET}/lib cp -v ${PRRFIX}/lib/crtn.o /cross-tool/${CLFS_TARGET}/lib cp -v ${PRRFIX}/lib/crt1.o /cross-tool/${CLFS_TARGET}/lib This will prevent the failure which it's output is: crti.o: No such file: No such file or directory gcc build or crtn.o: No such file: No such file or directory gcc build

Then also: cp -v ${PRRFIX}/lib/libm.a /cross-tool/${CLFS_TARGET}/lib should be executed. To prevent the failure with the error message: Link tests are not allowed after GCC_NO_EXECUTABLES

Change History

comment:1 Changed 10 years ago by chris@…

This is most likely the result of user error. Double-check what you typed first before assuming the book needs an addition, and use the clfs-support mailing list, not the Trac system, for issues building the book.

comment:2 Changed 10 years ago by jciccone

  • Status changed from new to closed
  • Resolution set to invalid

First, $PREFIX is not set anywhere in the book. Second, you're making a HUGE assumption that the host system and the target system are compatible with each other. This is definitely a user error. This error would be caused by one or more of three things. Either you did not properly install glibc, you did not apply the specs patch to gcc, or you did not use /tools but thought another prefix might work without modifying the specs patch.

Note: See TracTickets for help on using tickets.