Ticket #1095 (new task)

Opened 2 years ago

Last modified 2 years ago

Host System Requirements Check

Reported by: kb0iic Owned by: clfs-commits@…
Priority: trivial Milestone: CLFS Standard 3.1.0
Component: BOOK Version: CLFS Standard GIT
Keywords: Cc: berzerkula@…, jonathan@…, chris@…, cross-lfs@…

Description (last modified by kb0iic) (diff)

Chris mentioned the notion to check our Host System Requirements section.

I have been testing with the updated lfs livecd which is based on 6.3 with my own updates:  http://clfs.org/~kb0iic/livecdupd/

So far GCC needs to be upgraded to at least 4.2.3 because of newer Binutils and GOLD Linker requirements and the heavy use of templates. A 4.1.2 compiler can only work if using the 4.1.3 prerelease fixes (4.1.3 was never released). This is why I say GCC should at least use 4.2.3 as of now. Same issue with 4.2.0, 4.2.1, and 4.2.2. 4.2.3 is fine.

ISL 0.15 has a header issue at ctx.h line 83 which causes issues with older compilers regarding C99 and a comma existing at the end of an enumeration. During ISL cross-tools install:

cp -v include/isl/ctx.h{,.orig}
sed '83/s/.$//' include/isl/ctx.h.orig > include/isl/ctx.h

 https://groups.google.com/d/msg/isl-development/olvv6MU_3gE/VMf8qzZLCQAJ

Editing the header in ISL for cross-tools is best no matter which host compiler version is used.

Chris found some issues, but I'm still at gcc-static right now.

Change History

comment:1 Changed 2 years ago by kb0iic

  • Description modified (diff)

comment:2 Changed 2 years ago by kb0iic

  • Description modified (diff)

comment:3 Changed 2 years ago by kb0iic

Okay, kept getting segmentation faults with glibc 2.22 after building gcc-static and it was consistent. I think it has to do with how old the lfs livecd setup is. I'm going to test with slackware 12.1 which has GCC 4.2.3. I should also test slackware 12.0 which has 4.1.2, but it's a pure 4.1.2 and probably would have the same issues with binutils gold as the livecd with 4.1.2.

comment:4 Changed 2 years ago by kb0iic

Well since our kernel requirement is of 2.6.32, we should be fine in most host requirements. Distros at that time were using gcc 4.4. I don't think we need a host requirements page, but a distro requirement. or both. The kernel requirement is only cause of glibc because of with-kernel-version option, and the toolchain requirement is critical. It's a mess really.

Note: See TracTickets for help on using tickets.