Ticket #1084 (closed defect: worksforme)

Opened 2 years ago

Last modified 21 months ago

Texinfo 6.0 cross compile makedoc error

Reported by: kb0iic Owned by: clfs-commits@…
Priority: major Milestone: CLFS Sysvinit 3.1.0
Component: BOOK Version: CLFS Standard GIT
Keywords: Cc: berzerkula@…, jonathan@…, chris@…, cross-lfs@…

Description

I upgraded Texinfo 6.0 with no issues during pure 64 bit, but I don't think I used a 32 host when doing so. With Texinfo 6.0 I get this error:

/bin/bash: ../tools/info/makedoc: No such file or directory

It will be built with 64bit instructions.

Sooooo... we need to make sure that makedoc or the docs are skipped for install. Looking into this.

Change History

comment:1 Changed 2 years ago by kb0iic

shovel through it and use:

Use

make -k

problem solved

comment:2 Changed 21 months ago by blackadder

No problems here with a pure 64 bit build

comment:3 follow-up: ↓ 4 Changed 21 months ago by kb0iic

If the host can run the target's binaries, then the problem won't be seen. It is when the host cannot run the target's binaries that it will be a problem. x86_64 64bit to x86_64 pure64 bit the problem won't crop up. 32bit x86_64 or x86 to x86_64 64bit where the 32bit host cannot run 64bit binaries, the problem exists. Texinfo attempts to generate and run the tools, but doesn't know it is cross-compiling or doesn't detect it, and builds the tools for the target and not for the host.

comment:4 in reply to: ↑ 3 Changed 21 months ago by blackadder

Replying to kb0iic:

If the host can run the target's binaries, then the problem won't be seen. It is when the host cannot run the target's binaries that it will be a problem. x86_64 64bit to x86_64 pure64 bit the problem won't crop up. 32bit x86_64 or x86 to x86_64 64bit where the 32bit host cannot run 64bit binaries, the problem exists. Texinfo attempts to generate and run the tools, but doesn't know it is cross-compiling or doesn't detect it, and builds the tools for the target and not for the host.

Still didn't see any problems x86 32 bit to x86_64 pure.

comment:5 Changed 21 months ago by kb0iic

  • Status changed from new to closed
  • Resolution set to worksforme

Odd, I'm using a slackware-current build from 32bit for pure 64 bit and texinfo built fine. I had been using 32 bit debian hosts for testing. Well since I can't reproduce this, I'm closing it.

Note: See TracTickets for help on using tickets.